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Preface

This manual supports the Buffer Analyzer demo.

Other documents are available on the Tektronix Web site (www.tektronix.com/
manuals):

H MTS400 Series MPEG Test System Quick Start User Manual (English
071--2607--xx and Japanese 071--2608--xx).

H MTS400 Series Generator Applications User Manual (077-0204-xx).

H MTS400 Series Analyzer Applications User Manual (077-0205-xx).

H MTS400 Series Carousel Applications User Manual (077-0203-xx).

H MTS400 Series MPEG Test System Programmer Manual (077-0206-xx).
This manual specifies the remote control and status monitoring interfaces
available to a management application.

H MTS400 Series Specifications and Performance Verification Technical
Reference Manual (077--0207--xx).

Manual Conventions
The following formatting conventions apply to this manual:

H Bold text refers to specific interface elements that you are instructed to
select, click, or clear.
Example: Select Settings from the Configuration menu.

H Mono--spaced text can indicate the following:

H Text you enter from a keyboard.
Example: Enter the network identity (http://TSMonitor01).

H Characters you press on your keyboard.
Example: Press CTRL+C to copy the selected text.

H Paths to components on your hard drive.
Example: The program files are installed at the following location:
C:\Program Files\Tektronix\.
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Introduction to the Demo Version

The T_STD Buffer Analyzer (Demo version) models the behavior of the buffers
in the hypothetical Transport Stream System Target Decoder, as specified in
ISO/IEC 13818-1. It processes the video, audio, and system control default
sample stream.

The demo supports only one transport stream, which contains the elementary
stream of H.264 video, MPEG2 video, AAC audio, and AC3 audio.

Installing the Program
You can download the BufferAnalyserSetup.exe file from
www.tektronix.com/software and follow these steps to install the demo version
of the Buffer Analyzer.

1. Double-click the BufferAnalyserSetup.exe to start the InstallShield Wizard
that installs the Buffer Analyzer demo version on your computer. Click Next
to continue.
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2. Click Install to begin the installation.

The InstallShield Wizard installs the application and displays the progress.
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3. Click Finish to exit the Wizard after the demo version is successfully
installed.

Starting the Program
Start the program by selecting the Buffer Analyser option from the Start > Pro-
grams > Tektronix (Demo version) > Analysers menu or by double-clicking the
Tektronix Buffer Analyser (Demo version) shortcut on the desktop.
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When the demo program starts and is ready for use, it opens a main window as
follows:

The title bar of the main window shows Buffer Analyser to be a demo version.

The demo version of the application supports all menus and options that are
available in the full version except for the File menu options. The File menu
options available when the application has just started, or after a file is closed,
are listed in Table 1--1:

Table 1- 1: File menu options for demo version

Command Function

Open Sample Stream Creates a Buffer Model Results (BMR) file using the sample TS file
for analysis. The BMR file will not be saved.

Open... Disabled for the Buffer Analyzer Demo version.

Print Setup... Opens a dialog box for selecting the printer and the associated
options to use.

Recent File Disabled for the Buffer Analyzer Demo version.

Exit Stops running the program.

Initial Appearance

Initial Menu Options
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Opening a File
When you select the Open Sample Stream option from the File menu, the
sample TS file is automatically loaded and displayed in the Buffer Analyzer
window. In this version, the Stream File dialog box (from where a file is
selected) does not open and you will not be able to save the results of the
analyzed TS file.

NOTE. The Open and Recent File options are disabled because you can load
only the Sample TS file provided with this application.

The toolbar contains a shortcut for opening the sample stream file.

The Stream List window opens after the sample BMR file is loaded. The
application inspects the file to find the program streams that are present
according to the Packet Interpretation setting.

Window Layout
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Once the file is open, the program performs initial analysis to form the Stream
List and calculates the mean transport rate. All further analysis and processing of
streams are the same as the full version application and are described in the
following sections.

NOTE. When PID 32 and PID 33 of the stream list are processed, the elementary
buffers overflow and underflow. During overflow, the elementary buffer
occupancy goes above the 100% level. During underflow, the elementary buffer
occupancy goes below the 0% level.
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Getting Started

The T_STD Buffer Analyzer (Full version) models the behavior of the buffers in
the hypothetical Transport Stream System Target Decoder, as specified in
ISO/IEC 13818-1. It can process video, audio, and system control streams. The
results of the analysis are displayed as graphs of the buffer capacity over time
and a log of exceptions and noteworthy events.

Suitable Streams
Any valid MPEG file, recorded or synthesized, can be processed by this
application. A valid file is one that starts on a transport stream (TS) packet
boundary (the first byte of the file must contain the first byte of a TS packet).

The Buffer Analyzer will process video, audio, and system control streams that
are compliant with the 1996 standard ISO/IEC 13818 parts 1-3.

The Buffer Analyzer is able to analyze the following types of elementary
streams: MPEG1 Audio and Video, MPEG2 Audio and Video, H.264 Video,
MPEG2 AAC Audio, MPEG4 Audio (Only LC and SBR profiles) and AC3
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Audio. The full version of the Buffer Analyzer supports HEAAC along with the
above elementary streams.

The Buffer Analyzer will handle transport streams that contain PCR and/or
PTS/DTS discontinuities. The PTS/DTS and PCR in a stream must, however,
use the same time base.

Buffer Analyzer is unable to work on scrambled streams. If it fails to make sense
of a stream, use TS Analyzer to determine if the stream is scrambled.

Table Handling

Buffer Analyzer forms a list of elementary streams that are present in the
transport stream. This is called the Stream List. It creates the Stream List by
reading the first occurrence of the Program Association Table (PAT) and Program
Map Table (PMT).

If more than one version of the PAT and/or PMT are present, TS Cutter can be
used to isolate a particular section for analysis.

Only PIDs carrying MPEG-2 PSI tables are included in the System model. Any
DVB or ATSC tables that are present in the Transport Stream are ignored.

Starting the Program
To start the program, select the Tektronix Buffer Analyser option from the
Start > Programs menu or double click the Tektronix Buffer Analyser Shortcut
on the desktop.

Multiple PAT and PMT
Versions

MPEG-2, DVB and ATSC
Tables
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Once the program has started and is ready for use, it will open a main window.
When the program starts, the main window looks like the following illustration:

The toolbar (row of buttons above the dark gray area of the empty window) can
be hidden from view, moved to a separate window, or moved to either side or the
bottom of the main window.

The status line at the very bottom of the window can be hidden from view. It
displays information about the application and keyboard status.

The application presents different menus and options, depending on whether a
file is open for analysis. The menu options available when the Buffer Analyzer
has just been started, or after a file is closed, are shown in Tables 2--1 and 2--2:

Initial Appearance

Initial Menu Options
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File Menu Options. Table 2--1 lists the File menu options.

Table 2- 1: File menu options

Command Function

New Opens a stream file for analysis and opens or creates a Buffer Model
Results (BMR) file in which to store the results.

The application opens a file selection dialog box allowing you to
choose the stream file. It then opens another file selector dialog box
to specify the BMR file.

Open... Opens an existing BMR file to review results of a previous analysis.
The application opens the file selection dialog box allowing you to
choose the required file.

Print Setup... Opens a dialog box for selecting which printer and associated
options to use.

1 <filename>
2 <filename>
3 <filename>
4 <filename>

A list of the four most recently used BMR files. If the Buffer Analyzer
has recently been installed, the list may hold less than four files.

Selecting a file name opens that BMR file for review.

Exit Finishes running the program.

View Menu Options. Table 2--2 lists the View menu options.

Table 2- 2: View menu options

Command Function

Toolbar Displays or hides the toolbar.

Status Bar Displays or hides the status bar.

Settings… Opens the Settings dialog for specifying Video Buffer Sizes and
Video Data Transfer method.

(A check mark next to an option shows that the toolbar is currently visible; no check mark
means that it is hidden.)

Settings
Various configuration parameters, including Packet Interpretation, Pre-Scan
Packets, PES Private Interpretation, Video Buffer Sizes, Video Data Transfer
method, and Audio Buffer sizes can be modified before and after opening an
MPEG file. When a file is open, one or more streams can be analyzed, the
settings can be changed, and then other streams can be analyzed with the new
settings. If the settings are changed, the MPEG file must be closed and opened
again to reanalyze the streams analyzed with previous settings.
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It is a good idea to check the settings before opening a file to verify the method
with which video streams will be analyzed.

Select Settings... from the View menu.

This opens the Settings dialog box, which has three tabs: System, Video and
Audio.

These options can be set only before analyzing a file. They are disabled (grayed
out) while a file is open.

The MPEG2 / ATSC option is available on ATSC or ATSC/DVB dual standard
MPEG Test System products. It is disabled (grayed out) on single standard DVB
systems.

Packet Interpretation. Specifies which standards will be used for interpreting the
packets in the Transport Stream when a file is opened for analysis. The options
are:

MPEG2 Interprets the packets according to the standards for
DVB streams.

System Settings
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MPEG2 / ATSC Interprets the packets according to the ATSC standards.
This option is required if AC-3 audio stream content
will be analyzed.

Pre-Scan Packets.During the initial processing of an MPEG file, a number of
packets are prescanned for information that will result in a more accurate
analysis of the initial parts of the transport stream. The greater the number of
prescanned packets, the greater the chance of locating all of the information
required for accurate analysis. The drawback is increased processing time. By
default, 10000 packets are prescanned, which should be sufficient for most
streams, excluding High Definition Video.

All Packets Select this check box to cause all packets to be pres-
canned. The packets field will be disabled (grayed out).

Packets If the All Packets check box is not selected, enter the
number of packets to be prescanned in this field.

PES Private Interpretation. This setting specifies the model type to use for streams
signaled as PES Private (stream_type = 6).

The selections available include the following: AC-3 Audio, AAC Audio,
MPEG-2 Audio and Video, MPEG--4 Audio, H264 Video and System. The
default setting is AC-3 Audio.

Video Settings
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Buffer Sizes. Specifies the sizes that will be used for the Main and Elementary
Buffers, when interpreting the stream. The options are:

Automatic Automatically detects the buffer sizes from the Sequence
Headers and Extensions in the elementary stream being
processed. This is the default option when the applica-
tion is started.

Manual Enables the size of the Main or Multiplex buffer (MB)
and Elementary Buffer (EB) to be specified manually.
The MB and EB fields are available for editing when
this option is enabled.

Data Transfer. By default, the Buffer Analyzer inspects the stream to determine
which transfer method to use. This can be overridden if required. The options
are:

Automatic Examines the stream to determine the transfer method.
This is the default option when the application is started.

Leak Method Initiates modeling of the stream using the Leak Method.
H.264 streams support only this method but the option
can be kept as Automatic.

VBV Delay Method Initiates modeling of the stream using the Video Buffer
Verifier (VBV) Delay Method. This option is specific to
MPEG-2.

Default Frame Rate. The frame rate is one of the parameters that is searched for
during the prescan phase of analysis. However, if it is not found, the default
value selected from the drop-down list in the Default Frame Rate field is used.
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Buffer Size. Specifies the size that will be used for the audio buffer when
interpreting the stream. The options are as follows:

Automatic Automatically detects the buffer sizes from the Sequence
Headers and Extensions in the elementary stream being
processed. This is the default option when the applica-
tion is started.

Manual Enables the size of the buffer (B) to be specified manu-
ally. The B field is available for editing when this option
is enabled.

AAC. Select the number of AAC channels required from the drop-down list.

Within the ADTS (Audio Data Transfer Stream) fixed header, the channel
configuration field is used to indicate the number of channels required by AAC.
If the number in this field is zero, the value in the AAC Default channels field is
used.

The associated ADIF (Audio Data Interchange Format) is unsupported.

Refer to Information technology –
Generic coding of moving pictures and associated information,
Part 7: Advanced Audio Coding (AAC) ISO/IEC 13818-7:1997

NOTE. If the settings are modified, the new settings are used for all video streams
that are subsequently processed. The settings are reset to the default option when
the application is started.

Audio Settings
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Opening an MPEG File
Any file holding a recorded or synthesized sample of a Transport Stream that
carries video, audio, and/or system control streams can be analyzed. These files
are referred to as MPEG files to distinguish them from Buffer Model Results
(BMR) files. The results of analysis are written to a BMR file.

To open a file for analysis, select the New option from the File menu. Alterna-
tively, use the Ctrl+N keyboard shortcut.

NOTE. The list of previously used files shows BMR not MPEG files, as can be
seen by their .bmr extension.

The toolbar contains a shortcut for the New command.

In response to the New command, the Buffer Analyzer opens a file selection
dialog to choose an MPEG file for processing. When the MPEG file has been
chosen, the MPEG file selector closes and another file selection dialog opens.
This is for choosing a Buffer Model Results File (BMR), which holds the results
of any analysis performed on the MPEG file.

NOTE. Choosing an existing BMR file will erase all results that had previously
been saved in that file.

The Buffer Analyzer suggests an output file with the same name as the MPEG
file but a file extension of .bmr to hold the Buffer Model Results. Select OK if
you want to accept the suggested filename. Otherwise, select a different file or
type in a different name and then select OK.

Opening a File from the
Menus and Toolbar
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Opening a BMR File
An existing Buffer Model Results (BMR) file can be opened to review the results
saved in it from previous Buffer Model Analysis.

To open a BMR file, select the Open... option from the File menu. Alternatively,
you can use the Ctrl+O keyboard shortcut.

If the required file is in the list of recently analyzed BMR files, it can be opened
from the list to save using the open file dialog.

The toolbar contains a shortcut for opening a file:

Opening a File from the
Menus and Toolbar
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Window Layout
The Stream List window opens as soon as either an MPEG or BMR file is
opened. The application inspects the file to find what program streams are
present according to the Packet Interpretation setting, as shown in the following
illustration:

Initial Processing of MPEG Files
If an MPEG file is opened, the program performs initial analysis to form the
Stream List and calculate the mean transport rate. All streams in the list are
marked as Unprocessed, because no analysis has been performed on them in this
session.

To build the Stream List, the MPEG file is scanned for the PAT and PMT table
contents. It is assumed that the contents are constant, which is usually the case. If
the program changes drastically, such as streams disappearing between PMTs,
the model will give meaningless results.

Only the first occurrence of complete PAT and PMT are read when forming the
Stream List. Use TS Cutter to isolate a section when multiple versions of the
tables occur.

A number of packets in the file are scanned for the Sequence Header and
Extension start codes (containing profile and level) (see Settings, page 10). If
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they are not found, the Main Profile and Level settings are assumed together
with the maximum VBV buffer size.

Initial Processing of BMR Files
If a BMR file is opened, the State column indicates which streams were
processed. The file only holds results for those streams marked as Processed. To
obtain results for unprocessed streams, the original MPEG file will have to be
opened again and analyzed.
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Menus and Controls

When a file is open, the program presents a different set of menus and options.
They change as soon as the Stream List window appears. For example, the Open
file commands are replaced by Close file commands.

Toolbar

The Toolbar provides the following shortcuts for frequently used menu options:

Opens dialog boxes to select an MPEG file for analysis and a BMR file for saving the
results. This button is disabled (grayed out) when a file is open.

Opens a dialog box to select a BMR file to review the results of a previous analysis
session. This button is disabled (grayed out) when a file is open.

Closes the current file. This button becomes available the moment a file is opened. If
the wrong file is being opened, or the wrong options are selected, clicking on the
button will abandon the analysis and close the file.

Opens the Settings dialog box.

Prints the contents of the current window.

Opens a dialog box that displays the program version number.

Analyzes the stream(s) from the PID(s), that are currently selected in the
Stream List. This button is only enabled when one or more PIDs that are marked as
unprocessed are selected.

The next group of five buttons open Results Views for the selected streams.

Opens a graph of the Transport Buffer for the selected stream. This button is only
enabled when the PID of a Processed stream is selected in the Stream List window.

Opens a graph of the Multiplexing Buffer of a video stream; Main Buffer of an audio
stream or of a system information stream. The button is only enabled when the PID
of a Processed stream is selected in the Stream List.

Opens a graph of the Elementary Stream Buffer for the selected video stream. This
option is available only when a PID carrying a Processed Video stream is selected in
the Stream List.
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Opens the Event Log for the selected stream. The button is enabled only when the
PID of a Processed stream is selected in the Stream List window.

Opens all of the relevant graphs and the event log for the selected stream. This
option is available only when a PID carrying a Processed Video stream is selected in
the Stream List.

The remaining buttons control display options for Graphs of buffer analysis
results.

Draw all points toggles the graph displays between having all points drawn and
sampling the points for drawing.

Synchronize Graphs toggles the graphs between using the same position and zoom
settings or operating independently.

Auto Scale toggles the selected graph between fixed and auto scaling of the y axis.

Zoom In increases the magnification along the x-axis (time scale) of the currently
selected graph. All graphs are affected if Synchronize Graphs is enabled.

Zoom Out reduces the magnification along the x-axis (time scale) of the currently
selected graph. All graphs are affected if Synchronize Graphs is enabled.

Reset Zoom resets the magnification of the currently selected graph from zoomed to
original state.

Trace analyzes the message logs. You can view the message log that is produced by
the Buffer Analyzer.

The Toolbar can be dragged off the edge of the main window into a floating
pallet. To do this, place the mouse pointer on the background inside the toolbar,
(not on one of the buttons), hold the left button down, and drag into the main
window area. The result is a self-contained window that looks like this:

To replace the toolbar on the window border, drag it over the border, until the
outline changes shape, and release it. It can be placed on the top, bottom, left or
right edge.
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Status Bar

The status bar might be hidden from view, but if it is visible, it is always at the
bottom of the main window. The status bar can be displayed by selecting Status
Bar option from the View menu. It displays the following information about the
program and keyboard states:
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Menu Options
Tables 2--3 to 2--10 list the available menu options.

Table 2- 3: File menu options

Command Function

Close Closes the current file. This option is available as soon as analysis
starts. If the wrong file is being opened, or the wrong options are
selected, selecting this option will abandon the analysis and close
the file.

Print Prints contents of the current window.

Print Preview Prints contents of the current window.

Print Setup Selects printer and configuration.

Trace Print
O ti

Font Selects the font to be used for printing text.
Options Colors Not available with Buffer Analyzer.

Exit Closes any file that is open and terminates the program.

Table 2- 4: Edit menu options

Command Function

Cut Moves the currently selected records from the main window to the
clipboard.

Copy Copies the contents of the currently selected records to the
clipboard. They are not removed from the main window.

Delete Deletes the selected records from the main window.

Delete Except Deletes all records except those selected from the main window.

Delete All Deletes all records.

Select All Selects all records.

Table 2- 5: View menu options

Command Function

Toolbar Shows or hides the Toolbar.

Status Bar Shows or hides the Status Bar.

Settings… Opens the Settings dialog box.

Global Event Log Shows or hides the Global Event Log window.

Transport Buffer Opens a graph of the Transport Buffer for the selected PID.
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Table 2- 5: View menu options (Cont.)

Command Function

Main Buffer Opens a graph for the selected PID in the Stream List. The graph
shows results for the Main Buffer of audio and system streams or the
Multiplex Buffer for video streams.

Elementary Buffer Opens a graph of the Elementary Buffer for the selected PID.

PID Event Log Displays the Event Log for the selected PID.

All Buffers Opens all graphs and the log for the selected PID.

Trace Generates a detailed trace log.

Table 2- 6: Options menu options

Command Function

Draw All Points Toggles between drawing all points on the graphs, and drawing every
nth point. ‘n’ is calculated from the total number of data points and
the screen space for the graph.

Synchronize Views Toggles the graphs between using the same position and zoom
settings and operating independently.

Auto Scale % Axis Toggles the selected graph between fixed and auto scaling of the y
axis.

Table 2- 7: Process menu options

Command Function

Process Streams Applies the stream(s) from the PID(s) selected in the Stream List to
the System Target Decoder Buffer Model.

This option is enabled only when one or more unprocessed PIDs are
selected in the Stream List.

Table 2- 8: Trace menu options

Command Function

View

Column Opens the column definition dialog box for selecting the columns of
information to be displayed.

Font Selects the font that is used for displaying the text of detail message
log records.
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Table 2- 8: Trace menu options (Cont.)

Command Function

Colors.... Selects background and text colors that are used to display each
type of message.

Newest End Displays the newest record.

Show

Markers Shows markers permanently while using Trace with the Buffer
Analyzer.

General Text Shows or hides general messages, such as messages indicating the
start of processing for a particular PID.

Fixed Shows or hides information such as transport rates and buffer sizes.

PCR Timestamp Shows or hides messages about PCRs and associated instanta-
neous transport rates.

System... Selects which types of system messages to show.

Audio... Selects which types of audio messages to show.

Video... Selects which types of video messages to show.

Table 2- 9: Window menu options

Command Function

Cascade Cascades the windows.

Tile Tiles the windows.

Arrange Icons Arranges any minimized windows along the bottom of the main
window. Aligns icons of any minimized windows at the bottom of the
program’s main window.

1 <window file> Lists all of the available windows. A check mark indicates the active
window. Select an option to bring that window to the top.
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Table 2- 10: Help menu options

Command Function

About Buffer Analyser… Opens a dialog box that displays the program version number.
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Stream List

The Stream List is displayed in the form of a tree view. The tree view is grouped
and sorted by the program numbers with the label for the PIDs, stream types, and
the states that are displayed. The Stream List displays all the elementary streams
in the file. An unprocessed state is indicated by the black label and the processed
state is indicated by the green label.

The ‘+’ symbol displayed to the left of some icons indicates that the item
includes lower-level stream components that are not displayed. The symbol
changes to ‘–’ when the lower level components are displayed. To expand the
hierarchy, click on the ‘+’ symbol. To collapse the hierarchy, click on the ‘–’ of
the selected upper-level icon.

The System, Audio, and Video PIDs of a specific program number are displayed
as leaf nodes of the same level.

Stream Type includes Video, Audio, AC-3 Audio, AAC Audio, System, or
Private. Private streams cannot be processed, but may show more information
about the type, such as ISO/IEC 13818 Auxiliary. The Packet Interpretation from
the System tab of the Settings dialog box sets the standard that is used for
identifying these types.

The preceding example is from a DVB compliant transport stream.
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An ATSC stream might look like this:

This tree view lists processed (analyzed in the buffer model) and unprocessed
streams. A stream can be processed only once when the file is open. To process a
stream again, the file must be closed and then opened again.

When an MPEG file is first opened, the program streams are all marked as
Unprocessed, which indicates that no buffer analysis has been performed in this
session so far.

If a BMR file is opened, the streams state will be displayed as processed or
unprocessed. The file only holds results for those streams marked as Processed.
To obtain results for unprocessed streams, the original MPEG file must be
reopened and analyzed.
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Selecting Streams
To analyze or open the results views for a stream or streams, the streams must
first be selected in the Stream List. To select a stream, click on the PID number.

For example, click PID 1 Stream Type text to select the Video stream carried in
PID 1.

By using the Shift and Control keys, you can make multiple selections for all the
tree nodes.

You can select the highest level node to process all the descendent nodes. For
example, selecting the highest level transport stream node will process all the
PIDs or selecting a specific program level node will process all the PIDs of that
program.

To select a contiguous range of streams: click on the first stream’s PID, and then
hold the Shift orY key down and click on the last stream’s PID number. If the
required streams are not adjacent, hold the Ctrl key down, and click the PID
number for each stream.

All streams can be deselected by clicking the mouse pointer outside the tree view
data. To deselect a particular stream while leaving the others selected, hold the
Ctrl key down and click the stream’s PID number.

Processing Streams
When one or more streams are selected from Stream List, they can be analyzed
in the buffer model.

To start analysis, select the Process Streams option from the Process menu.
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Alternatively, click on the Process button in the toolbar.

You can also process the highlighted streams by selecting Process Streams from
the shortcut menu.

When H.264 streams with SEI (HRD) parameters are processed, a dialog box is
displayed, prompting you to either continue or abort the processing of streams. If
you continue, the STD leak method will be used for analysis. If you abort the
process, the state of that stream will be displayed as aborted.
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NOTE. For HRD model analysis, use a Tektronix ES Stream Analyzer (MTS4EA).

Buffer Analyzer supports six Profiles for MPEG-2 video: Simple, Main, SNR,
Spatial, High, and High4.2.2.

Buffer Analyzer supports seven Profiles for H.264: Baseline, Main, Extended,
High, High10, High4.2.2, and High4.4.4.

It supports four Levels: High, High - 1440, Main, and Low.

Details of valid combinations of profile and level are given in standards
document ISO/IEC 13818 part 2 section 8.5.

The hypothetical T-STD specified in ISO/IEC 13818 part 1 section 2.4.2
assumes a processing steady state. To handle the start-up processing before
reaching the steady state, the Buffer Analyzer performs as follows:

H The fraction of the first video frame leading up to the first picture start code
is not passed through the Buffer Analyzer. This is because it is not possible
to determine whether the Leak or VBV Delay method is being used. During
this period, the PES header, Sequence Header, and Extension information are
extracted. This information is used to determine the initial DTS, size of the
MB and EB buffers.

H The Decoding Time Stamp (DTS) for the first frame is assumed to be
correct. It is used as a base for the timing of all subsequent frames. MB
underflow errors are suppressed during the first frame.

If the DTS of the first frame is not correct, use TS Cutter to remove the suspect
frame(s) from the file.

Supported Profiles &
Levels

Start-Up
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The application uses the following approximations to model the behavior of the
hypothetical T-STD:

H Data is processed one packet (188 bytes) at a time. An underflow/overflow
condition that occurs and clears within the period of one packet will be
missed.

H Processing one packet at a time causes the buffers to be emptied in block
fashion, thus giving a stepped graphical output.

H Slight quantization effects occur because the model is processed at discrete
time intervals, corresponding to a single packet length. This may affect the
VBV Delay calculations. The timing intervals for transferring frames from
MB to EB are dynamically adjusted to compensate.

Approximations



Buffer Analyzer (Demo) User Manual 33

Event and Message Logs

The T-STD Buffer Analyzer allows you to access the Global Event log and the
PID Event log. You can use the Trace to create a log containing a more detailed
analysis of the entire process.

The views can be synchronized by selecting the Synchronize Views option from
the Options menu. While Synchronize Views is enabled, a change to any view is
immediately applied to all the other views.

Global Event Log

The Global Event Log displays: reports from the initial analysis, PID indepen-
dent information (Transport Stream errors) and high level details for each stream
processed.

For details of events detected during the processing of a stream, open the PID
Event Log for that stream.
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PID Event Log

An Event Log window can be opened for each PID that has been or is currently
being processed. Results are written to the log as they are produced. All time and
packet numbers are given, relative to the start of the file.

Selecting an event row from the Event Log will place a cursor at that time in
each of the Buffer Results graphs. To select an event, click the row of the desired
event.

To deselect an event, click the mouse pointer outside the data column.

Trace
The Trace is used for analyzing the message logs produced by the Buffer
Analyzer. The message logs may be useful for in-depth analysis of the internal
processing, particularly for the video stream type. Trace has filtering capabilities
that allow you to focus on message types of particular interest.

Event Selection
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Trace record is displayed only for processed streams.

To start Trace, select the Trace option from the View menu.

Alternatively, click the Trace button in the toolbar.

Trace displays the detailed message log in the main window. It has a status bar at
the bottom of the window and a scroll bar on the right side.

The status bar can be hidden from view, but when it is visible, it is always at the
bottom of the main window. The status bar is dispalyed by selecting the Status
Bar option from the View menu bar.

The trace window displays the detailed message records in a table format. Each
record is represented by a single row of the table. The window displays buffer
sizes, transfer rates, profiles, levels, and frame rates that are used for the analysis.
It also displays the data movements between buffers and their occupancies with
respect to time and packet numbers.

The example shows a log in which a PID (PID 17) carrying video was analyzed
and then another PID (PID 20) carrying audio was analyzed.

The types of messages that are displayed in the trace window are selected from
the Show menu.

User Interface

Detailed Message
Records
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To move forward and backward through the log, use the scroll bar on the right of
the window, the Page Up, Page Down, Cursor Up Arrow, and Cursor Down
Arrow Keys.

NOTE. If more than one PID is processed concurrently by the Buffer Analyzer, the
records will be interleaved in the Trace display. Unless this interleaving is
required, processing one PID at a time will make it easier to follow the messages
for each stream.

Records can be selected for printing, copying, deleting, and other Edit menu
operations. To do this, they must first be selected.

A single record can be selected by clicking on it. To select a contiguous range of
streams, click the first record to be selected and then hold the Shift down and
click the last required record. Alternatively, click the first record, hold the left
mouse button down and drag the pointer to the last record.

Selected records are repainted in the highlight color scheme. By default, this is
black text on a magenta background. For example:

The selected records can be edited and viewed by using the shortcut menu
option. You can edit (cut, copy, delete) records, define the Trace (column, font,
colors), and select messages (System, Audio, Video) to be displayed in the Trace.
You can also show or hide general text, fixed, and time stamp features.

Selecting Records
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To set the columns of information that are displayed in the Trace table, select the
Column option from the View menu.

Enabled (checked) column options will show in the Trace table. Click an option
to change its state.

Column Options
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The font of the messages displayed in the Trace table can be changed using the
Font dialog box.

You can select the font, font style, size, and script from this dialog box. A
sample of the selected font is displayed in the Sample display box. Click OK to
see the selected font in the Trace table.

Fonts
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The color scheme for each message type and for highlighting selections can be
changed using the Select Colors dialog box.

To modify the color schemes, select the Colors option from the View Menu. This
opens the Select Colors dialog box.

Select the message type to be changed from the list box on the left. The current
color scheme will be displayed in the Sample under the list box. Click the
swatch (colored square) in the Text Color and Background panels for the
required text and background colors.

Repeat the procedure for each message type that is to be changed and click OK.

The Reset button restores the selected message type to the default color scheme.
The Reset All button restores all of the color schemes to their defaults.

Color Schemes
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Results Graphs

The results of the analysis are plotted on a separate graph for each buffer. When a
graph is opened for a stream that is still being processed, each result is plotted as
soon as it is produced from the model.

All of the graphs have a similar format and controls.

Common Features

All of the graphs plot time from the start of file on the x-axis and current space
used in the buffer on the y-axis. You can zoom--in and zoom--out horizontally
and vertically, simultaneously.

When the results graph is first opened, the entire graph is shown. Even a small
file can display data points packed too closely to see the features clearly. For
example, here is just under 20 seconds of a video stream that generated several
events:

The Axes

Zoom
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Even this small sample holds some solid bands of blue lines and green event
markers, from which only general trends can be determined.

To change the time scale (x-axis) to resolve finer detail, click on the Zoom In
button on the toolbar:

Zoom in as many times as required to achieve the desired magnification. The
magnification is doubled each time the button is clicked.
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In this example, clicking the Zoom In button three times gave a much clearer
view:

To Zoom back out, click the Zoom Out button as many times as required:

Each time the Zoom Out button is clicked, the magnification is halved, until the
full graph is again displayed.

The slider at the bottom of the window indicates where the displayed area is in
relation to the rest of the file. It can be used to scroll the display through the
graph in a similar way to a window scroll bar.

View Bar
Shows size and position
of visible area of the
graph within the file.

Slider Control
Shows either: the center of the visible
area of the graph, or the position of the
cursor in both the file and visible area.

Earliest
time in
View

Latest
time in
View

End of fileStart of file

To scroll the stream through the view:

H Drag the Slider Control left or right with the mouse.

Scrolling the View
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H Click the mouse pointer in the slider bar (either the clear sections or the view
bar) to the side of the Slider Control.

When a time or event is selected on the graph, the Slider Control is automatically
repositioned within the View Bar. The placement of the Slider Control reflects
the position of the selected packet in the field of view.

A graph can show one or more green triangular markers along the top. Each
marker indicates the time a particular event, listed in the PID Event Log,
occurred.

Only events that relate to the points plotted on the graph are displayed in that
graph. For example, an event relating to a Video Multiplex Buffer will only be
marked on the Video Multiplex graph and not on the Elementary or Transport
Buffer graphs.

Double-clicking a marker will display a pop-up window. This shows the time
and a brief description of the event that is marked.

Event Markers
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For example, selecting an event relating to the Elementary Buffer from the Event
Log of a video stream will place a cursor at the time of the event in the buffer
results graphs. Looking at the graphs, a marker of the event has been placed on
the Elementary Buffer graph, but not the Multiplex Buffer graph.
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Graphs of results can be open for one or more streams. For each stream, one or
more graphs can be displayed. The graphs can have their zoom, cursor position
and visible section manipulated separately, or all the graphs can be synchronized.
For example, in unsynchronized operation, the open graphs might look like this:

This pair of graphs shows different periods in the file at different magnifications.

To synchronize the views, select the Synchronize Views option from the Options
menu.

Synchronize Views
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Alternatively, click on the equivalent shortcut button.

This will apply the zoom, cursor, and visible section of the active window to all
of the other graphs. While Synchronize Views is enabled, a change to any graph
is immediately applied to all the other graphs.

The Trace table can also be synchronized with the other graphs by enabling the
Synchronize Views icon. While Synchronize views is enabled, a change in the
selected event of the Trace table moves the cursor position of all other graphs
accordingly. Similarly, a change in any of the graphs moves the highlighted
event of the Trace table accordingly.



T-STD Buffer Analyzer - Results Graphs

Buffer Analyzer (Demo) User Manual 49

To separate the control of the graphs, disable synchronize views by selecting the
menu option or by clicking the shortcut button again.

The cursor can be repositioned within a graph by clicking the required point.
This is useful when Synchronize Views is selected as a way of marking the same
time in all the graphs for ease of comparison.

The scale on the y-axis of the graphs shows space used in the buffer as a
percentage of total space. By default, all of the graphs have a vertical scale that
goes from -50% to 200%. The following illustration shows an example graph.

Selection

Auto Scale
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Selecting the Auto Scale %Axis option from the Options menu changes the
y-axis for the active graph.

Alternatively, select the equivalent shortcut button.

The y-axis is now drawn so that the full scale contains the range of values in the
graph, to the nearest 25%. For example, if the range of values was from 30% to
64%, the y-axis would go from 25% to 75%.

The earlier example will be rescaled to look like the following illustration.
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To revert to the default scale, select the menu option or click on the shortcut
button again.

The graphs often contain more data points than can be resolved on the screen. By
default, to avoid drawing points on top of each other, the application will plot
every nth point. This also speeds up the drawing process. How many points to
plot is determined from the available width of the graph on the screen and the
total number of points to plot.

Use the Draw All Points option to look for outlying points and to resolve the fine
detail when the display is zoomed in on the data.

Selecting the DrawAll Points option from the Option menu will cause the
application to plot every point.

Alternatively, select the equivalent shortcut button.

Drawing all points may take much longer for larger files than the default option.
The option can be disabled by clicking the shortcut button again or deselecting
the option from the menu. This can be done even while redrawing the graphs.

Draw All Points
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Elementary Buffer Graph

An Elementary Buffer graph can only be opened for Video Streams, since these
are the only types of streams that have an elementary buffer.

Elementary Buffers are not allowed to overflow, so the graph of the results never
goes above 100%. The graph uses the scale -50% to +250% to make comparison
easy.

Multiplex or Main Buffer Graph

For Video streams, this graph shows the results for modeling a Multiplex buffer.
For Audio and System Control streams, the graph shows the results for the Main
buffer. The title bar shows the stream type.
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Here is an example to show the title for a graph of a System Control stream.

Transport Buffer Graph

The Transport Buffer graph shows the results of modeling the Transport buffer
for Video, Audio, or System Control streams. The type of stream is shown in the
title bar. In the above example, the results plotted are for a video stream carried
in PID 310.
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Here is an example of an audio stream.
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